Degraded Performance

Incident Report for Receipt Hog

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 19:22 UTC

Monitoring

App performance should be returning to normal. We will continue to monitor things closely.
Posted Jul 15, 2025 - 18:22 UTC

Investigating

We are currently investigating an issue causing degraded performance. Further updates will be posted as they become available.
Posted Jul 15, 2025 - 17:54 UTC
This incident affected: Mobile Applications (Receipt Hog iOS, Receipt Hog Android), Receipt Processing (Email Processing, Receipt Image Processing, Link Processing), and Sign In & Registration.