Degraded performance
Incident Report for
Receipt Hog
Resolved
This incident has been resolved.
Posted
Jul
23
,
2022
-
01:48
UTC
Update
We are continuing to investigate this issue.
Posted
Jul
23
,
2022
-
00:53
UTC
Investigating
We are currently investigating this issue.
Posted
Jul
23
,
2022
-
00:45
UTC
This incident affected: Mobile Applications (Receipt Hog iOS, Receipt Hog Android).
×
Subscribe to Incident
Subscribe to updates for
Degraded performance
via . You'll receive .